[Resolved] Secure Connection failed while trying to purchase the SK Pro


#1

Hi again mad scientists. There seems to be a problem with the next link:
https://skookumscript.com/gopro/

The main site appears to have the SSL certificate revoked.


#2

Thanks! We will look into it.

[If you are trying to purchase the SkookumIDE Pro, then double thanks!]

I don’t seem to have a problem with that link and page. It loads and when I refresh, it still seems fine and has the SSL lock :lock: icon.

In what way does the page seem to be having a problem?


#3

Well, when i go to the gopro link this page is shown:
Capture

PD: I’m not using a VPN and i tried with other browsers.


#4

Fun. Thanks.

We will try to solve it on our end.

You are connecting in from Lima, Peru - right? [I had a great trip there 10 years ago. Wow, has it been that long?]

If it takes a while, we will figure out a way to get you a copy of the SkookumIDE Pro more quickly.


#5

Yep, i’m connecting from Cusco-Perú actually :grin:
BTW, maybe there’s something wrong with my PC settings. The page loaded in my phone…


#6

If you find out any more, we would appreciate hearing about it.

Cusco was the home base where I stayed for 3 weeks while I did the Inca Trail, etc. Awesome to hear that game development is going on there. :madsci:


#7

I tried with an “old” laptop with windows 8.1 and the problem is still there. Maybe it’s a windows related issue? I’m using windows 10 in my PC.


#8

I’ve been researching it.

It seems that it is somewhat browser related.

It works with the Chrome browser and it does not work with Firefox/Mozilla.

I just tried it on Firefox and MS Edge and I get the same issue.

Would you be able to try Chrome until we figure out how to fix this?


#9

It’s really nice to know that you visited us in the past. You guys from agog labs are awesome!


#10

No, it didn’t work with chrome neither in my laptop or my pc.


#11

There is obviously something wrong. :thinking:

What doe this SSL Checker report for you?
https://www.sslshopper.com/index.php?q=ssl-checker.html#hostname=https://skookumscript.com/gopro/

It says that the certificate is still good for 102 days for me.

If needed, we will generate you a custom coupon to get you a copy of the SkookumIDE Pro.


#12

Yeah, everything is checked (green) and it says that the certificate expires in 102 days.

Also, i just purchased the Pro license using my phone :grin:


#13

Awesome! Let us know how the SkookumIDE Pro works out for you.

Thanks for alerting us to this SSL issue. We’ll figure it out.


#14

UPDATE: I asked a friend to see if he could open the link. He can’t open the link neither but he was able to open it using a local proxy: https://github.com/zaproxy/zaproxy/wiki/Downloads


#15

We’ve found out that our SSL certificate issuer made a mistake with the certificate and they revoked it to fix it and issue a new one. It should be resolved in a day or two.

Thanks again for letting us know about it.


#16

This issue has been fixed. All should be back to normal. Thanks for hanging in there!


#17

NP. I can confirm it’s working now.