Exclude SkookumScript plugin from compilation?


#1

Hey guys.

Since :sk: works best if it’s placed in the ProjectName/Plugins/ folder i was wondering if there’s a way of excludind :sk: from the compilation.

I usually need to delete the project generated folders (Intermediate, Binaries, etc) so i can Generate Visual Studio project files again, open the .sln and build my source files. The problem here is that :sk: is also compiling and increasing about 120-150 seconds to this process.

So i’m wondering if there is a way of excluding the :sk: plugin from the compilation?

I also have some batch files that does the process i wrote:

"C:\UE4Path\UnrealBuildTool.exe" -projectfiles -project="C:\MyProject\MyProject.uproject" -game -rocket -progress
"C:\UE4Path\Build.bat" MyProjectEditor Win64 development "C:\MyProject\MyProject.uproject" -waitmutex

By using these commands, i’m not sure if there’s a way of exclude a plugin by using a command line argument.
Also, there may be a way of excluding a plugin by modifying the MyProject.uproject file since:

Plugins": [
		{
			"Name": "SkookumScript",
			"Enabled": false, //If false, SK won't be compiled.
			"MarketplaceURL": "com.epicgames.launcher://ue/marketplace/content/38694f554c2c4b9f84c585256d509481"
		}
	]

I may be wondering if there’s an extra parameter i can use in the plugin section so the plugin can be enabled but also excluded from the compilation?


#2

We’ve moved most (or even all) of the project functionality into the SkookumScript plugin even when it is still an engine rather than a project plugin.

We’ll confirm that if there is still any extra benefit to having the SkookumScript plugin as a project plugin rather than an engine plugin and get back to you… :thinking:


#3

Hi!
I’m also using some third party plugins which i, think, it’s mandatory to have it located in the Project/Plugins/ folder.

I moved the :sk: plugin to the “Marketplace” folder but my 3rd party plugins are located in Project/Plugins/ so :sk: detects the plugin modules. It seems to be working fine with this setup but it could be better if i could move the 3rd party plugins to the Marketplace folder too.

If i try to move my 3rd party plugins to the marketplace folder, VS will show me this warning and :sk: won’t detect the modules:
Module 'PluginModule' specified in game project SkookumScript.ini file is not a game module. Currently, only game modules are supported. No bindings will be generated for it.

I’ve found a workaround tho. I’m deleting all the generated folders with the exception of Project\Intermediate\Build\ActionHistory.bin. Seems to be working fine. Plugins located in Project/Plugins/ aren’t compiled if i rebuild the project now.

Also, i’m interested in adding the “Paper2d” module to :sk: but i’m also seeing the same warning. I suppose that if i copy the “Paper2d” plugin to my Project/Plugins/ folder it will work fine. But is there another way?


#4

Have you tried changing "EnabledByDefault" : true in SkookumScript.uplugin to false?