Compiled binary file is stale, engine is newer!


#1

I’m updating :sk: to latest/greatest in Arconia and am running into some issues. To help level the playing field I’ve completely removed the scripts folder from my project and completed my 4.14 update without sk: in the mix.

Now trying to add :sk: in I’m getting this on launch:

SkookumScript loading previously parsed compiled binary...
  Loading compiled binary symbol file 'D:/Hypercane/perforce/Arconia/Intermediate/SkookumScript/Content/SkookumScript/classes.sk-sym'...
  Loading compiled binary file 'D:/Hypercane/perforce/Arconia/Intermediate/SkookumScript/Content/SkookumScript/classes.sk-bin'...
  Compiled binary file is stale, engine is newer!

Hitting ok results in:

###Error : Compiled binaries must be loaded to be able to bind.

  C++ Internal Info:
    void __cdecl SkUERuntime::bind_compiled_scripts(bool,class SkClass **,unsigned int)
    D:\Hypercane\perforce\UnrealEngine\Engine\Plugins\SkookumScript\Source\SkookumScriptRuntime\Private\Bindings\SkUERuntime.cpp(361) :
    Test failed: m_is_compiled_scripts_loaded
SkookumScript binding with C++ routines...

I’ve tried blowing away these intermediate files to make sure they get refreshed as well as cleaning UHT. Can’t seem to get passed this. I have a lot of C++ UMG stuff in this project that could perhaps be causing issues, so am wondering if there might be a good entry point for me to see some debug so I can add some modules to the blacklist.

I can package things up if needed but was hoping I may have missed something obvious.


#2

Oops! This is happening because of inconsistent merging to the licensee branch. You have a newer version of the runtime but still an older IDE. We’ll discuss how to fix this properly and let you know when we have posted an update. Sorry for the trouble!


#3

I can always just revert back to an earlier changelist if that’s easier.


#4

Yeah you’d have to sync to before 3826 for this bug to go away.


#5

I was getting the same error yesterday and forgot to post it. Glad to see error454 was on top of this! :wink:


#6

Ok this should be fixed now. Get latest and let us know!


#7

Confirmed! :madsci: