Can't connect to P4 w/SSL


#1

My Perforce server runs with SSL enabled and I noticed that I’m unable to setup source control in the new IDE (ssl:server.com:port). I remember having a similar issue in the :ue4: editor around the 4.9 era.

If I try looking for workspaces nothing comes back, typing a workspace in by hand and hitting accept settings just doesn’t grays the window out for a sec. No output is generated in the :ue4: output window.


#2

Hmm we use SSL as well and it works fine for us. When you enter your P4 settings, does it say it’s connected and display the green badge on the Source Control button? I assume you didn’t forgte to enter your workspace in the workspace field?


#3

I don’t get a green badge, I can’t close the window without hitting Run Without Source Control.
My UE4 editor has the green badge and is working as expected and I have P4V running to make sure my session is valid.


#4

Did you check that the SkookumIDE is not blocked by your firewall?


#5

I just attempted disabling firewall and the results are the same.


#6

Hmm odd. You could download P4D, run it locally and try to connect to it, see if that works.

Or, try attaching VS2015 to the SkookumIDE and check if you see any log prints that provide more information on the VS2015 Output pane.


#7

I was trying to investigate this, attaching debuggers, looking at P4 logs etc but never got any logging out of it. The last thing I did was kill the :sk: IDE window right after I had unsuccessfully hit the accept button. Next time I launched :sk:, it was connected with the green checkmark.

Still if I open up the source control window and hit accept, I get the same behavior. So I’m just killing it and moving on for now.


#8

Wondering: Do you get the same issue connecting to either our or your own P4?


#9

Right I left that out. The p4 server I’m connecting to right now is on my local network, I usually connect to it remotely through a forwarded port but have tried both:
ssl:local_ip:local_port
ssl:remote_ip:forwarded_port

Both have the same result. I also tried throwing your guys P4 server stuff in there. I’ll have to get my other box out and see if results are reproducible in my network or if it’s box specific.