Can't Build SkookumScript Plugin (Solved - needed Git LFS enabled)


#1

Hi,
First time I’ve tried to build this in Visual Studio and need some help. I got UE4 to compile and run without Skookum Script, but when I add the Skookum plugin, the build fails.

I followed the steps here For C++/Visual Studio users

and get this error when I open UE4.sln and build as the Skookum lib files are 1kb.

34>C:\UnrealEngine-release\Engine\Plugins\SkookumScript\Source\AgogCore\Lib\Win64\VS2015\AgogCore-Win64-Development.lib : fatal error LNK1107: invalid or corrupt file: cannot read at 0x83


Newbie question about Github
#2

This looks like you don’t have Git LFS enabled on your git.


#3

Thanks that seems to have fixed it.

I wasn’t sure what was meant by that step. This explains it: