3.0.1897 Beta - get your hands on it!


#1

So here’s how to get the latest greatest:

If you got your SkookumScript plugin from GitHub, just pull from your respective branch (4.9, 4.10 or master).

For those of you using the precompiled engine installed via the Epic Games Launcher, here’s our plugin in precompiled form (sorry now that UE 4.10 is released we are dropping support for UE4.8).

Find latest downloads here.

Install as usual and enjoy!

See the latest post in the Unreal Engine 4 Plugin category for a detailed list of what’s new in this release!


#2

Hey Markus,

After installing this version and then attempting to run the latest demo (SkookumDemo 3.0.1856), I ran into this compiler error:

ERROR: The method ‘teleport_actor()’ does not exist for an instance of the class ‘Actor’.
Actor.named(“RoboChar1”).teleport_actor(“TargetPoint1”)
Actor.named(“RoboChar2”).teleport_actor(“TargetPoint2”)
Actor.named(“RoboChar3”).teleport_actor(“TargetPoint3”)

File: D:\Unreal Projects\SkookumDemo\Scripts\Project\Object\Mind\Master\SkookumDemo\robo_reset().sk[254-268]

I suspect you renamed teleport_actor to teleport_to_actor. I replaced the calls and recompiled successfully. You might want to update the demo to account for this change.

Cheers,
Shadi


#3

Hi Shadi,

Thanks for trying out SkookumScript! The demo you downloaded is not the latest demo. :slight_smile: You need to download the demo with the same build number as the plugin you downloaded (1897). See the main post for the 1897 release.


#4

Oh whoops! My bad; didn’t see that there was a main post. Still getting used to this forum format! Thanks! :slight_smile:


#5

Yeah sorry for the confusion - since the Beta Releases category is private to only beta Testers, we split each new release into two posts, one with the announcements and public downloads, and one with the private download links. Probably will group the demo project downloads with the plugin downloads next time to reduce confusion.


#6

I am trying to make a “simple” editor with Skookum.

I tried using Widgets buy are unsure on how to adress them in Skookum script?

Most scripts just have pawns and Actors in there samples.

I also found this when I created a Widget with most components.

All these are unsupported :

Button
CheckBox
CircularThrobber
ComboBoxString
EditableText
EditableTextBox
EditableTextBox
Image
InvalidationBox
MenuAnchor
MultiLineEditableText
MultiLineEditableTextBox
NamedSlot _35
NamedSlot _64
ProgressBar
SafeZone
Slider
SpinBox
Throbber
WidgetSwitcher

And I am wondering if I should use Unreals slate and Skookum and if that works?

Regards

Lee


#7

Hi Lee,

Try adding UMG to your script supported plugins:

Open Engine\Programs\UnrealHeaderTool\Config\DefaultEngine.ini and add a line +ScriptSupportedModules=UMG to it.

That should fix your issues.


#8

Well… I have a problem running Skookum IDE. After installation of plugin when I start Unreal Engine it stops loading after 79%. It just stops and waits forever. After restart (of PC) I tried to launch SkookumIDE.exe located in:
C:\Program Files\Epic Games\4.10\Engine\Plugins\SkookumScript\Runtime\SkookumIDE
It won’t start either. Nothing is displayed, but when computer is shutting down Program Manager process is blocking it for couple of seconds so looks like it still tries to start the IDE.

I tried this version of plugin for 4.10 and 4.9 and also I tried 3.0.1773 version of plugin. Always the same problem. I also tried to set compatibility with Windows 7. I am currently using Windows 10.

Is there something I can do? It is the first time I am trying to use Skookum.


#9

Hi Xkonti thanks for trying out SkookumScript! It appears like your problem is that the SkookumIDE does not launch. This is the first time I hear of the IDE not starting up - odd. Are you sure UE4 waits forever? It should time out after a while if it cannot connect to the IDE. What version of Windows are you using? Are you running Windows natively or in a virtual container? If so, there might be some problem with the TCP/IP connection between the engine and the IDE. Do you have a particular security software or firewall installed that might be blocking the IDE from launching? There could be a dialog window hidden somewhere asking you for permission. You can use ALT-TAB to cycle through the open windows to find out. Hope you can figure it out. If not, let me know and we can think about next steps to make it work.


#10

The SkookumIDE uses the Internet (TCP\IP) to connect to the Unreal Editor/Runtime. Most Internet firewalls will initially block access to SkookumIDE until you give it permission - this is even if the IDE and UE4 are both running on the same MS Windows computer.

You may have to add a firewall exception (maybe even by hand) for both the SkookumIDE and for the Unreal Editor / runtime before the SkookumIDE can be run.

I run the SkookumIDE on both MS Windows 7 pro and Windows 10 pro. Any Windows edition 7 and above should be fine.


#11

@GreatGuru @Noolarch I just figured it out. Avast Free Antivirus didn’t liked it. It is weird because Avast almost always shows window about scanning new exe. I had to add Skookum to whitelist for scanning and DeepScreen. After that (and PC restart) IDE started correctly and firewall asked for permission, so it is all good now.
Sorry for premature post, but it still may be helpful for other people :wink: